Error "There is already an item in the collection that has the specified key" appears when accessing the MailEnable Administration Program.


SYMPTOMS

Error "There is already an item in the collection that has the specified key" appears when accessing the MailEnable Administration Program.

CAUSE

This error indicates that there is a corruption in the underlying MailEnable configuration files. This error should only occur with MailEnable if there are duplicate entries in the configuration files.

RESOLUTION

If this error occurs when selecting the Mailboxes branch in the MailEnable Administration Program, then it is most likely that there are duplicate entries in the Mailbox.tab file under the CONFIG\POSTOFFICES\[Postoffice] directory.

Edit this file using Notepad and ensure that the file does not contain duplicate entries.

MORE INFORMATION

The formats for MailEnable configuration files are outlined in the System Configuration Manual. There is also a configuration utility which explains how to recover the mailbox.tab file for a post office.

Please see: http://www.mailenable.com/kb/content/article.asp?ID=ME020156



Product:MailEnable (All Versions)
Article:ME020248
Module:General
Keywords:MMC,There,is,already,an,item,in,the,collection,that,has,specified,key
Class:ERR: Product Error
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable