System filter does not process messages


SYMPTOMS

A filter has been configured but it does not seem to pick up anything.

CAUSE

This issue may occur if MailEnable's intergrated filtering is not configured correctly.

RESOLUTION

  • The first thing is to check if the filtering is enabled for the MTA agent. To check this navigate to this location in the MailEnable Adminstration program. Messaging Manager > Servers > localhost > Filters - right click on "filters" and check the enable tickbox to enable the filtering option.
  • MailEnable content filters match strings/letter patterns within the mail messages.When specifying filter criteria, consider the format of the message content and the impact that this may have on the string patterns used in criteria/word lists.  If a message is encoded as rich text or HTML, the string patterns in the content of the message may be somewhat different to those apparent when viewing the message.
  • For example, HTML and rich text messages may embed tags around the words or letters within a message and the filter criteria may need to use wildcards to effectively match the message content.
  • It is possible to verify if the filtering is functioning by checking the MTAFILTER-Report-date.txt log file which will indicate what filter,criteria and actions were used on the message. This log file can be found by navigating to this location in the MailEnable Administration program: 
    Servers > localhost > Filters > MailEnable Message filter > logs > Filter . To further investigate, run the MTA in debug mode. This will display the MTA's activity and display if the filters are being met and what actions are being executed.

Also, run the Diagnostic Report to ensure that the product license key is valid, as filters will be disabled if the evaluation has expired or the license key is invalid.

MORE INFORMATION

More information on how to run the MTA in debug mode can be found here: http://www.mailenable.com/kb/content/article.asp?ID=ME020121

Troubleshooting Integrated Filtering: http://www.mailenable.com/kb/content/article.asp?ID=ME020386

Global/Mailbox Filtering - Troubleshooter: http://www.mailenable.com/kb/content/article.asp?ID=ME020356

Server Level Filter Agent Troubleshooting: http://www.mailenable.com/kb/content/article.asp?ID=ME020348

 



Product:MailEnable (Pro-Any Pro-1.X Ent-Any Ent-1.X)
Category:Configuration
Article:ME020377
Module:MTA Filtering
Keywords:Filtering,MTA,debug,filter,configuration,system,not,processing,process,picking
Class:PRB: Product Problem or Issue
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable