Filter actions do not appear to be working


SYMPTOMS

Filter actions have been configured but they do not appear to be executing.

CAUSE

Filter actions can appear not to be working if the "Delete message" action executes before other actions configured within the filter.

RESOLUTION

Ensure the action to "Delete message" is not first in the actions list, as this will delete the message before any further filter actions can run on the message. This can also cause spam notifications not to be sent to either the sender or the recipient.

Verify what actions are being executed when the criteria is met by checking your MTAFILTER-Report.txt which indicates which filter was called, criteria used and actions executed.

MORE INFORMATION

Global/Mailbox Filtering - Troubleshooting: http://www.mailenable.com/kb/content/article.asp?ID=ME020356

Server Level Filter Agent Troubleshooting: http://www.mailenable.com/kb/content/article.asp?ID=ME020348



Product:MailEnable (Pro-Any Pro-1.X Ent-Any Ent-1.X)
Category:Configuration
Article:ME020378
Module:MTA Filtering
Keywords:Filtering,actions,delete,filter,not,working,executing,action,execute
Class:PRB: Product Problem or Issue
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable