Messages not getting delivered to the Junk E-mail folder


SYMPTOMS

The filter action to "Mark message as spam" has been configured but mail that meets the criteria is not being delivered to the Junk E-mail folder.

CAUSE

Messages marked as spam are not being delivered to the Junk E-mail folder. This can occur for one of the following reasons:

  • If the option to "Deliver junk email to Junk E-mail folder" is not enabled under the "Features" tab under the "Post Office" Properties window. (Enterprise edition only) 
  • The mailbox has whitelisted the sender domain or email address. The user can check this under their webmail Whitelist options.
  • "Junk E-Mail Processing" option under Servers->localhost->Extensions properties window is set to "Messages are moved Inbox".
  • Another filter action is changing the X-ME-Content header.

RESOLUTION

Enabling a higher level of debug logging for the postoffice connector will give more details of what is happening when the message is being delivered. To enable a higher debug log level, please see:

Article ME020585

If the message is still received in the inbox, check if the filter is working correctly by checking the messages header values. The criteria to "Mark as spam" should add the following line in the header details of the message. If this line does not exist, the message will not be sent to junk.

X-ME-Content: Deliver-To=Junk

MORE INFORMATION

Server Level Filter Agent Troubleshooting: Article ME020348



Product:MailEnable (Ent-Any Ent-1.X)
Category:Configuration
Article:ME020379
Module:MTA Filtering
Keywords:Junk Email SPAM header mark message as spam not delivered, mark as spam,
Class:PRB: Product Problem or Issue
Revised:Thursday, October 14, 2021
Author:
Publisher:MailEnable