SYMPTOMS
A mail
client can send to locally serviced domains
on the MailEnable server but not to remote domains.
Error returned by mail client when unable to send to remote servers:
The message could not be sent because one of the
recipients was rejected by the server. The rejected e-mail address was 'user@domainname'. Subject 'test',
Account: 'localhost', Server: 'localhost', Protocol: SMTP, Server Response: '503
This mail server requires authentication when attempting to send to a non-local
e-mail address. Please check your mail client settings or contact your
administrator to verify that the domain or address is defined for this server.',
Port: 25, Secure(SSL): No, Server Error: 503, Error Number:
0x800CCC79
CAUSE
The most likely reasons for this
follow;
- MailEnable has not been configured to allow relay
for authenticated users or the mail client has not been configured to authenticate against
the MailEnable SMTP connector
- The AUTH Extension was not reported in the EHLO
response from the server because the extension or verb for AUTH or EHLO have
been disabled
- The mail client is configured
to connect through an SMTP proxy or firewall and is not directly hitting the mail
server at all. (E.g. Cisco PIX firewalls may use 'Mailguard' which does not
support SMTP AUTH. Therefore either disable the Mailguard feature on the firewall or
use POP before SMTP).
- The mail client does not
support SMTP Authentication.
RESOLUTION
Here are some possible
solutions:
- Ensure AUTH and EHLO are enabled; SMTP extensions in the
SMTP properties under the "Advanced SMTP" tab.
- Review the following
article on how to configure the CISCO pix firewall to allow correct
authentication:
http://www.mailenable.com/kb/content/article.asp?ID=ME020159
-
Mail client program does not support authentication. This is very unlikely, unless
using an old version of a mail client program. A list of compatible mail clients
is available in the following article:
http://www.mailenable.com/kb/content/article.asp?ID=ME020016
- Ensure the mail client has been configured correctly and "My
server requires authentication" has been enabled in the account properties if
using Microsoft Outlook or Outlook Express. More information on how
to correctly setup your mail client software can be found in the following
article:
http://www.mailenable.com/kb/content/article.asp?ID=ME020198
Here is
some detailed information relating to the process that occurs when a mail client connects to MailEnable and attempts to authenticate:
- When the client connects to the server, the server
sends the client a welcome message.
-
Then the client sends a EHLO command to the
server and the server will respond with a list of its supported
features.
- This is the default behaviour and if
it is not the case, then somehow the SMTP extension for EHLO or AUTH has
been disabled. Ensure that a firewall is not intercepting the EHLO or AUTH
request from the client, hence preventing SMTP authentication.
MORE INFORMATION
POP Before SMTP troubleshooting including - 503 Error
on relay: http://www.mailenable.com/kb/content/article.asp?ID=ME020327
Diagnosing POP and SMTP Authentication Problems:
http://www.mailenable.com/kb/content/article.asp?ID=ME020335
Error '503 This mail server
requires authentication': http://www.mailenable.com/kb/content/article.asp?ID=ME020135