Error "HTTP Error 404 - File or directory not found" occurs when accessing .NET web mail or web administration


SYMPTOMS

The error "HTTP Error 404 - File or directory not found" appears in the browser when attempting to access http://yourhost/mewebmail or http://yourhost/meadmin (even though web mail or web administration support has been configured for that web site).

CAUSE

This issue may occur if ASP.NET has not been installed/configured on the server.  MailEnable .NET web applications (i.e. web administration and web mail) require that ASP.NET is installed on the server.

RESOLUTION

ASP.NET needs to be installed on the server so that IIS understands how to process ASPX web pages. In some situations, it is possible that the .NET Framework is installed, however ASP.NET (Script Mappings for processing ASPX pages) may not have been configured.

To resolve the issue, it is necessary to install/configure ASP.NET for IIS on the server. There are two configuration changes that need to be made to IIS.

Enable the Web Service Extension (IIS Version 6 and later)

If using IIS 6 or later (i.e. Windows 2003 or later) access the Internet Service Manage (IIS Management Console) and check that the ASP.NET and ASP Web Service Extensions are allowed). If these were subsequently enabled, then test whether web mail and/or web admin function.

Configure ASP.NET Script Maps

If problems are still being experienced, it may be that the ASP.NET script maps have not been configured under IIS. A procedure for enabling them is outlined below:

1. Select Start, and then select Run.
2. In the Open text box, type cmd, and then press ENTER. 
3. At the command prompt, type the following, and then press ENTER:
"%windir%\Microsoft.NET\Framework\version\aspnet_regiis.exe" -i

In this path, version represents the version number of the .NET Framework that is installed on the server. This placeholder must be replaced with the actual version number when typing the command. 

For more information on aspnet_regiis.exe, please see:

http://msdn.microsoft.com/en-us/library/k6h9cz8h(VS.80).aspx

RELATED INFORMATION

Please also review this Microsoft Knowledge Base article: http://support.microsoft.com/kb/332124

This article can help with this error if the server extensions are not enabled: http://support.microsoft.com/?id=315122



Product:MailEnable (Pro-Any Ent-Any)
Category:Environment
Article:ME020433
Module:WebMail
Keywords:ASP.NET ASPX webmail webadmin http 404 error aspnet_regiis.exe aspnet_regiis,
Class:ERR: Product Error
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable