MailEnable Diagnostic Report indicates that the MailEnableAppPool has not been configured for one or more IIS Virtual Directories


SYMPTOMS

The MailEnable Diagnostic Report reports the following error:

The application pool for this site is "[AppPoolName]". This should be "MailEnableAppPool".

CAUSE

MailEnable Virtual Directories configured under IIS need to be configured to run under the MailEnableAppPool. This ensures that MailEnable web mail and web administration have the correct access rights to the MailEnable message store. If the MailEnableAppPool is not configured, there may be problems in modifying or deleting messages from the message store.

RESOLUTION

The MEInstaller.exe application (which is located in the MailEnable BIN directory) provides the ability to reset all relevant IIS Virtual Directories so that they run under the MailEnableAppPool.

Please follow these steps to reconfigure the Virtual Directories:

  • Navigate to the MailEnable BIN directory using the Windows Explorer.
  • Select the MEInstaller application to launch it.
  • Select the option to Reset IIS Virtual Directories and click the Execute button
  • The MEInstaller may prompt to specify the version of ASP.NET (.NET Framework) to use with MailEnable. Select the latest version from the list and then click OK.
  • Once the installer has completed, close the application and then attempt to access web mail.


Product:MailEnable (Pro-2.X Ent-2.X)
Category:Installation
Article:ME020435
Module:WebMail
Keywords:MailEnableAppPool,IIS,Virtual,Directory,ASPX,[AppPoolName],report,error
Class:PRB: Product Problem or Issue
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable