SYMPTOMS
Web mail and/or web administration may fail to function correctly when IIS6 is configured to run in IIS5 Process Isolation Mode.
CAUSE
When IIS is configured to run in IIS5 Process Isolation Mode, the MailEnableAppPool will not be used to host the MailEnable web mail/web admin applications. As such, there are likely to be permission issues accessing the MailEnable message and configuration stores.
SOLUTION
In both web.config files located in the roots of the .NET sites (under the MailEnable Bin directory), add (or replace) the XML values (inside <system.web> nodes) :
Quote:
<identity impersonate="true"
userName="registry:HKLM\Software\AspNetIdentity\WebMail\ASPNET_SETREG,userName"
password="registry:HKLM\Software\AspNetIdentity\WebMail\ASPNET_SETREG,password"
/>
Replacing:
<identity impersonate="false">
These files are text files, so they can be edited using Notepad.
Product: | MailEnable |
Category: | Integration |
Article: | ME020442 |
Module: | WebAdmin |
Keywords: | Process,Isolation,Mode,IIS6,IIS5,internet,information,service,server |
Class: | TRB: Troubleshooting (Configuration or Environment) |
Revised: | Wednesday, May 4, 2016 |
Author: | MailEnable |
Publisher: | MailEnable |