SYMPTOMS
ASP.NET versions of MailEnable web mail or web administration running on ASP.NET will not function and may report a Service Unavailable error through to the client browser.
The Windows Event Log may indicate that the MailEnableAppPool Application Pool could not be started.
CAUSE
Third party IIS Extensions may conflict with the MailEnableAppPool Application Pool. It is necessary that the identity of the MailEnableAppPool (IME_ADMIN) holds necessary permissions to execute any third party custom ISAPI filters that may be installed under IIS.
If this is not the case, then the MailEnableAppPool worker process may fail, resulting in a "Service Unavailable" message being returned to the requesting client.
RESOLUTION
Firstly, ensure that the IME_ADMIN user is a member of the IIS_WPG group. The MailEnable Diagnostic Report will warn if this is not the case.
Secondly, contact the author of any custom ISAPI extensions and inquire as to any "special permissions" (File System, Registry or Policies) that a worker process identity may need in order to integrate with the custom ISAPI extension.
WORKAROUND
If it is not possible to contact the relevant vendor, a workaround it to make IME_ADMIN a member of the Administrators group, so as to ensure that it has permissions to most/all system resources.
An alternative to the above is to use SysInternals (www.sysinternals.com) tools like FileMon, RegMon and TokenMon to profile the requirements of the ISAPI extension.
Product: | MailEnable (Pro-2.X Ent-2.X) |
Category: | Integration |
Article: | ME020451 |
Module: | WebMail |
Keywords: | Service,Unavailable,ASP.NET,ISAPI,Extensions,MailEnableAppPool,Application |
Class: | TRB: Troubleshooting (Configuration or Environment) |
Revised: | Wednesday, May 4, 2016 |
Author: | MailEnable |
Publisher: | MailEnable |