iPhone Apple mail client is not updating message flag status.


SYMPTOMS

Read/Unread flags are not being updated on Apple mail client on the iPhone. 

CAUSE

Apple mail on the iPhone is not updating the message flags even though the iPhone has received the correct IMAP FETCH details indicating the message flag status from the server. This scenario occurs after a message flag has been altered by the Apple mail client first and then a flag change is made by another email client. e.g Microsoft Outlook. The iPhone Apple mail client caches its earlier flag change and ignores any flag changes that have been made by other email clients until the account is disabled and enabled again within the iPhone mail account settings.

WORKAROUND

To update the flag changes you will need to enable/disable the account within the iPhone mail account settings. This the clears the client cache and displays the correct flag status.

For any further inquires about the Apple iPhone mail client flag issues, please contact Apple.



Product:MailEnable
Category:Other
Article:ME020554
Module:Other
Keywords:iPhone,Apple,mail,flags,IMAP
Class:BUG: Product Defect/Bug
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable