SYMPTOMS
If you are using Mozilla Thunderbird to access email via IMAP, and one or more other users are accessing the same mailbox you may not see their message flag changes. This is not necessarily visible if the account is the primary one, but if you are connecting to multiple mailboxes it maybe more obvious. While clicking off/on the folder does not help, restarting Thunderbird shows the correct values.
CAUSE
When Thunderbird is in IDLE mode, it accepts flag changes from other connections to that mailbox. As soon as it gets a change, it will drop out of idle mode though, to issue an NOOP to get information about changes. Since Thunderbird does not accept untagged responses when not in "idle", when it drops out of idle it may miss a subsequent flag change before going into idle mode again.
WORKAROUND
The solution is to disable IDLE support for the account in Thunderbird. This can be done by viewing the account in the Account Settings window, click the "Server Settings" for the account, then click the "Advanced" button under the Message Storage section. Unselect the "Use IDLE command if the server supports it". You will not get instant flag changes on the account, but if you are not looking at the Inbox, clicking it will show the correct state. Flag changes are updated depending on how often it is checking for new messages.
Product: | MailEnable |
Category: | Other |
Article: | ME020590 |
Module: | IMAP |
Keywords: | thunderbird,loss |
Class: | TRB: Troubleshooting (Configuration or Environment) |
Revised: | Wednesday, May 4, 2016 |
Author: | MailEnable |
Publisher: | MailEnable |