Outlook 2016 fails to copy files between folders when using ActiveSync


SYMPTOMS

When moving a group of messages from one folder in another in Microsoft Outlook 2016 all messages appear to move on the client, but the server has a different view, and only some of the messages are moved. This happens when you try to move messages soon after changing message flags in the source folder (i.e. marking messages as read).

CAUSE

Outlook 2016 is not sending up the move command for all the items. So only the items Outlook sends the details up for are moved. The server is not aware of any difference between the selected items and those sent by the client. The reason for not sending up all the items is that before Outlook sends the command to move the items, it sends a command to set the read flag of one of messages, but is asking to set the message flag in the destination folder, even though it does not exist there. The server sends a response indicating the message does not exist. It appears that when Outlook queues actions, it uses local message details when processing a queued action, rather than the message state at the time of queuing.

RESOLUTION

Recreate the account in Outlook. Since the client believes the messages are moved, further moves of those messages will fail, and Outlook will not sync the folders correctly. To prevent it happening avoid doing moves soon after flag changes. If you run version 9.61 or later of MailEnable, ActiveSync will not return a failure on the flag setting to the client if Outlook is detected. So it will prevent the move failure, but the message flag will not be set.

MORE INFORMATION

We will update this article when we receive details of a resolution in Outlook.

 



Product:MailEnable
Article:ME020656
Module:General
Keywords:activesync,outlook,2016
Class:PRB: Product Problem or Issue
Revised:Saturday, March 4, 2017
Author:
Publisher:MailEnable