SYMPTOMS
Messages sent to Gmail show a padlock with a line through it and when the mouse is hovered over this, a message indicates that the sender did not encrypt this message.
CAUSE
This occurs if the sending mail server did not use TLS encryption when sending the message via SMTP.
RESOLUTION
Firstly, make sure sending over TLS is enabled. This is done in the administration program. Expand the Servers->localhost->Services and Connectors branch, right click on the SMTP icon and select Properties from the popup menu. In the window that appears, click the Outbound tab and make sure Send using TLS if remote server supports it is enabled.
If your server does not have TLS 1.2 enabled, then it can fail to send to Gmail. Check the SMTP Debug log at the time of the send for any error in sending. Encryption errors will be logged.
Make sure that you are not going through another mail service, which may not be sending encrypted. If you smart host all your outbound email through a service, you will need to check with this service in order to resolve the issue.
If you are sending through a proxy/firewall it may be blocking the encryption by blocking the STARTTLS SMTP command. You may see this when you use telnet to connect to the Gmail SMTP service. Open a command prompt on your mail server and enter:
telnet gmail-smtp-in.l.google.com 25
This will connect to Gmail, you will see a welcome message line, and then you can enter this command to show whether STARTTLS is available:
ehlo there
You should see a result like:
e250-mx.google.com at your service, [x.x.x.x]
250-SIZE
157286400
250-8BITMIME
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-CHUNKING
250
SMTPUTF8
If STARTTLS is missing, it shows that you are going via another device doing SMTP filtering, and it will not send encrypted.
Product: | MailEnable (All Versions) |
Article: | ME020722 |
Module: | SMTP |
Keywords: | encrypt,gmail |
Class: | PRB: Product Problem or Issue |
Revised: | Thursday, January 14, 2021 |
Author: | MailEnable |
Publisher: | MailEnable |