When accessing web mail a .NET error is presented with stating 'Could not load file or assembly MailEnable.Core'.


SYMPTOMS

When accessing web mail a .NET error is presented with stating 'Could not load file or assembly MailEnable.Core'.

Server Error in '/' Application.

Could not load file or assembly 'MailEnable.Core, Version=2.0.0.0, Culture=neutral, PublicKeyToken=f27ae6111cfb0e37' or one of its dependencies. The system cannot find the file specified.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'MailEnable.Core, Version=2.0.0.0, Culture=neutral, PublicKeyToken=f27ae6111cfb0e37' or one of its dependencies. The system cannot find the file specified.

Source Error:

The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

1) Add a "Debug=true" directive at the top of the file that generated the error. Example:

<%@ Page Language="C#" Debug="true" %>

or:

2) Add the following section to the configuration file of your application:

<configuration>

<system.web>

<compilation debug="true"/>

</system.web>

</configuration>

Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.

Assembly Load Trace: The following information can be helpful to determine why the assembly 'MailEnable.Core, Version=2.0.0.0, Culture=neutral, PublicKeyToken=f27ae6111cfb0e37' could not be loaded.

CAUSE

Antivirus resident scanning software running on the MailEnable server has quarantined the MailEnable.Core.dll and removed it from the MailEnable web mail BIN folder (Mail Enable\bin\NETWebMail\bin).

RESOLUTION

  • Inspect the Antivirus application log files to determine if the resident filter was responsible for the removal of the file.
  • Use the Antivirus application recovery options to restore the file to the original location and remove from quarantine.
  • Exclude the MailEnable folder from the resident scanner.


Product:MailEnable (All Versions)
Article:ME020661
Module:General
Keywords:Mailenable.Core,mailenable.core,net,error,web,mail,webmail
Class:HOWTO: Product Instructions
Revised:Tuesday, February 21, 2017
Author:
Publisher:MailEnable